2 Replies Latest reply: Apr 30, 2014 3:01 PM by Christopher White RSS

We recently upgraded Cascade Profiler to 10.6.1

Kern Narva

and when I try to run a business report through our FlyScript portal it now fails so what do I need to update in FlyScript to reflect the upgrade to 10.6.1?

 

Server error:

Dependent Job failed: Analysis function failed:  for 2014-04-28 12:00:00+00:00-2014-04-29 03:00:00+00:00 failed: ["UnicodeDecodeError: 'utf8' codec can't decode byte 0xa0 in position 28953: invalid start byte\n"]

  • Re: We recently upgraded Cascade Profiler to 10.6.1
    Christopher White

    Hi Kern -- can you tell me which version of the code you are using?    Log in to the machine, cd to the directory where flyscript-portal is installed.

     

    If this was checked out from github, just run this command:

     

    $ git log -n 1 | cat

     

    If this was manually installed, run these two commands instead:

     

    $ md5 rvbd-portal/rvbd_portal/apps/datasource/models.py

    MD5 (rvbd-portal/rvbd_portal/apps/datasource/models.py) = 12ad699c38d8169d88e851d802dd7b2d

    $ ls -l rvbd-portal/rvbd_portal/apps/datasource/models.py

    48K -rw-r--r-- 1 cwhite wheel 45K Apr 30 15:33 rvbd-portal/rvbd_portal/apps/datasource/models.py

     

    I'll see if I can reproduce this in my environment.  I tried with a few versions of flyscript portal against both a 10.6 and 10.6.1 and I did not see this issue.

     

    If possible, can you send me the log.txt (privately if needed)?  That should shed some light on what's happening under the covers.

     

    One thought comes to mind -- is there possibly a new interface reporting that has an ifalias that has unicode characters in it?  

     

    Also -- what version did you upgrade from on Profiler?