• appresponse restful api

    Hello ,   How can i access the appreponse restful api without the appresponse framework?   Is there any document for restful api?   Thanks
    Anil Gorgec
    last modified by Anil Gorgec
  • SteelScript.AppResponse 1.1.1 using aggregates

    Hello ,   I have a question. How can I access the columns that can be used when using the source_name aggregates via general_report.py?   https://support.riverbed.com/apis/steelscript/appresponse/example...
    Anil Gorgec
    last modified by Anil Gorgec
  • appresponse framework 1.0

    Hello ,   I have a problem. I tried to connect to the framework with AppResponse .But I did not pass the following error. Appresponse version :Version: 11.2.1 #14398   Can you help me ?   My Code: ...
    Anil Gorgec
    last modified by Anil Gorgec
  • AppResponse 11 reports

    How could we extract response times for a given hostgroup (or connections , errors etc..) from ARX11 using steelscript? Are there any capabilities like in ARX9 (e.g restful web services) ?
    Stefanos Anastasiou
    last modified by Stefanos Anastasiou
  • Outbound traffic breakdown by host pair with port

    Hi, I want to recreate the table below using steelscript (table data left out on purpose).  I obtained the table below by using the 'interface report' selection. (Further screenshot at the bottom)    ...
    Sara Whang
    last modified by Sara Whang
  • Trouble passing login credentials to script in NetProfiler tutorial

    I am running through the SteelScript NetProfiler Tutorial (4.2.6).   I am trying to login and run the following script:   import optparse   from steelscript.netprofiler.core.filters import TimeFilter...
    Darryl Gratz
    last modified by Darryl Gratz
  • Report Output From NetProfiler SteelScript Tutorial

    Hello,   I am going through the NetProfiler SteelScript tutorial.   After running the sample script to generate myreport.py, I get the following report output:   [[u'10.100.6.12', 1773655.72778, u'']...
    Darryl Gratz
    last modified by Darryl Gratz
  • SteelScript NetShark API Slowness

    Hello,   So I am currently attempting to create a python script leveraging the SteelScript example file download.py. This script is supported to connect to a NetShark appliance, which it does, and then apply sev...
    Tyler Johnson
    last modified by Tyler Johnson
  • How to enable HTTPS from default HTTP configuration?

    How do I enable HTTPS communication on Steelscript App Framework versus default HTTP communication?   Simply commenting out the HTTP section and uncommenting the HTTPS section of the steelscript_appfwk_site_http...
    Neil Osuch
    last modified by Neil Osuch
  • I'm not a python coder

    I'm not a python coder  I'd like to use perl. I have create objects for many of the REST services. In the python SteelScript examples there appears to be a script which can send CLI commands and return the resul...
    Gary Panton
    last modified by Gary Panton
  • Error Processing Report Configuration

    Hi All, I was getting an error titled 'Error Processing Report Configuration' while trying to reload reports after copying a report from on of my other modules. Even after deleting the report, I was still getting the...
    Leigh Finch
    created by Leigh Finch
  • TypeError: rvbd.widgets[widgetModule] is undefined

    Hi All, I'm running the SteelScript 1.2 VM, and I'm trying to embed a widget into SteelCentral Portal. When I use the embed code I get a blank screen.   If I enter the URL within the code in my browser with dev...
    Leigh Finch
    last modified by Leigh Finch
  • Automating Workflow Using SteelScript/REST API

    Hi,   I'm looking at developing an automated workflow that is triggered by an SNMP trap sent from NetProfiler. Specifically I want to run a top talkers report from SteelScript (or via the REST API) when I receiv...
    Wil Bowes
    last modified by Wil Bowes
  • Shark update REST API

    Hey,   I'm looking to script an updgrade for our sharks/vsharks,  but I'm having issues with the "file upload".  Here is what my current script looks like:   #!/usr/bin/env python # -*- coding: u...
    Rossel Vermette
    last modified by Rossel Vermette
  • REST API - Internal Report Error 196609

    When I try to run a report I always get an error like so: [Internal Report Error. Unable to create table (error code: 196609).]   My test JSON file is very similar to one provided as an example on this forum (th...
    Mike Smith
    last modified by Mike Smith
  • How can I specify a hard start date using flowlist.py. if I use the -r option I get the correct end time but the start time is often days earlier than the specified start time

    How can I specify a hard start date using flowlist.py. if I use the -r option I get the correct end time but the start time is often days earlier than the specified start time. For example when I run the following &nb...
    Damon Henderson
    last modified by Damon Henderson
  • "InsecureRequestWarning: Unverified HTTPS request is being made.  Adding certificate verification is strongly advised."  How?

    We are trying to test some functionalities of SteelScript NetProfiler on our cascade netexpress 470 appliance in order to develop a customized application.   However, when executing the script we get the follow...
    Marcelo Fuenzalida
    last modified by Marcelo Fuenzalida
  • bug APScheduler steelscript.appfwk

    Hello,   It seems that using APScheduler 3.1.0 generates the following bug when generating a new workplace:   (venv_test)[steelscript@fr0-vsiaas-1642 steelscript]$ steel appfwk mkproject  -d test T...
    aaa
    last modified by aaa
  • Using NetProfiler to Monitor DHCP Address Distribution

    NetProfiler can provide many tools beyond just network monitoring. One useful tool is the ability to see how many network addresses are currently in use on specific subnets. With some straightforward SteelScript and P...
    jchessman
    last modified by jchessman
  • 10K UI Limit, removed with script?

    Hi, I ran a few reports using the "trafficsummary.py" script that is provided with steelscript.  I was under the impression that programmatically pulling this data allowed you to go beyond the 10,000 line limit t...
    Jamie Lozan
    last modified by Jamie Lozan